This repository has been archived on 2024-03-26. You can view files and clone it, but cannot push or open issues or pull requests.
nixos/hosts/charles/home.nix
Payas Relekar 5daf7e41b5 gitea -> forgejo
Also need to perform one-time migration:
https://nixos.org/manual/nixos/unstable/#module-forgejo
2024-03-16 17:01:07 +05:30

147 lines
3.7 KiB
Nix

{ config, pkgs, ... }:
{
imports = [
../../modules/neovim/nvim.nix
];
# Home Manager needs a bit of information about you and the paths it should
# manage.
home.username = "payasrelekar";
home.homeDirectory = "/Users/payasrelekar";
# This value determines the Home Manager release that your configuration is
# compatible with. This helps avoid breakage when a new Home Manager release
# introduces backwards incompatible changes.
#
# You should not change this value, even if you update Home Manager. If you do
# want to update the value, then make sure to first check the Home Manager
# release notes.
home.stateVersion = "23.05"; # Please read the comment before changing.
home = {
packages = with pkgs; [
rage
jq
fd
ripgrep
];
file = {
zsh = {
enable = true;
executable = false;
recursive = false;
source = ./zshrc;
target = "/Users/payasrelekar/.zshrc";
};
};
};
programs = {
home-manager.enable = true;
starship = {
enable = true;
settings = {
python.disabled = true;
ruby.disabled = true;
gcloud.disabled = true;
aws.disabled = false;
kubernetes.disabled = false;
};
};
ssh = {
enable = true;
matchBlocks = {
"ssh.bhankas.org" = {
user = "forgejo";
hostname = "ssh.bhankas.org";
identityFile = [ "~/.ssh/id_ed25519" ];
proxyCommand = "${pkgs.cloudflared}/bin/cloudflared access ssh --hostname %h";
};
};
};
git = {
enable = true;
aliases = {
br = "branch";
co = "checkout";
# last 5 commits in shortlog-style, with colors
last = "log -5 --abbrev-commit --pretty=format:\"%C(cyan)%h%Creset %C(yellow bold)%d%C(reset) %s %Cgreenby %an %cr%Creset\" HEAD";
# all history, in shortlog-style, with colors (short for colorlog)
cl = "log --abbrev-commit --pretty=format:\"%C(cyan)%h%Creset %C(yellow bold)%d%C(reset) %s %Cgreenby %an %cr%Creset\" HEAD";
};
userEmail = "payas.relekar@fplabs.tech";
userName = "Payas Relekar";
extraConfig = {
core = {
editor = "nvim";
};
merge = {
conflictstyle = "zdiff3";
};
rerere = {
enable = true;
autoUpdate = true;
};
};
delta = {
enable = true;
options = {
line-numbers = true;
side-by-side = true;
navigate = true;
};
};
};
bat.enable = true;
fzf = {
enable = true;
tmux.enableShellIntegration = true;
};
htop = {
enable = true;
settings = {
color_scheme = 6;
delay = 15;
fields = with config.lib.htop.fields; [
PID
USER
PERCENT_CPU
PERCENT_MEM
TIME
COMM
];
enable_mouse = 1;
highlight_deleted_exe = 1;
highlight_megabytes = 1;
highlight_threads = 1;
highlight_changes = 0;
highlight_changes_delay_secs = 5;
highlight_base_name = 1;
tree_view = 1;
tree_view_always_by_pid = 0;
cpu_count_from_one = 1;
show_cpu_usage = 1;
show_cpu_frequency = 1;
show_cpu_temperature = 1;
degree_fahrenheit = 0;
hide_function_bar = 0;
show_program_path = 0;
} // (with config.lib.htop; leftMeters [
(bar "LeftCPUs")
(bar "Memory")
(text "LoadAverage")
(text "Uptime")
]) // (with config.lib.htop; rightMeters [
(bar "RightCPUs")
(bar "Swap")
(text "Tasks")
(text "Systemd")
]);
};
};
}