This repository has been archived on 2024-03-26. You can view files and clone it, but cannot push or open issues or pull requests.
nixos/hosts/hermes/configuration.nix

60 lines
966 B
Nix

{ pkgs, ... }:
{
imports = [
./hardware-configuration.nix
./hardware.nix
./asus.nix
];
nixpkgs.config.allowUnfree = true;
system.stateVersion = "22.05";
networking = {
hostName = "hermes";
networkmanager.enable = true;
hosts = {
"192.168.0.7" = [ "bebop" ];
"192.168.0.164" = [ "titan" ];
"192.168.0.181" = [ "lapetus" ];
"192.168.0.239" = [ "rhea" ];
};
};
time.timeZone = "Asia/Kolkata";
documentation = {
enable = true;
man.enable = true;
};
# Enable CUPS to print documents.
services.printing.enable = true;
environment = {
etc = with pkgs; {
"graal".source = graalvm-ce;
};
};
programs = {
adb.enable = true;
direnv.enable = true;
dconf.enable = true;
nix-ld = {
enable = true;
libraries = with pkgs; [
zlib
fuse3
icu
nss
openssl
curl
expat
];
};
};
}