This repository has been archived on 2024-03-26. You can view files and clone it, but cannot push or open issues or pull requests.
nixos/hosts/hermes/hardware.nix
Payas Relekar 5244ad78d7 hermes: Boot with systemd initrd
This was an unfinished attempt at passwordless disk decryption. But for
now, it does not work. I'll need some decryption device/USB stick for
it, which I'm not currently willing to setup.

Anyway, will figure it out later. Got other prioriries now.
2023-12-26 19:25:24 +05:30

55 lines
1.2 KiB
Nix

{ pkgs, ... }:
{
boot = {
binfmt.emulatedSystems = [ "aarch64-linux" ];
loader = {
systemd-boot = {
enable = true;
consoleMode = "max"; # auto/keep
};
efi = {
canTouchEfiVariables = true;
efiSysMountPoint = "/boot/efi";
};
};
supportedFilesystems = [ "ntfs" ];
initrd = {
systemd = {
enable = true;
};
# Setup keyfile
secrets = {
"/crypto_keyfile.bin" = null;
};
# Enable swap on luks
luks.devices."luks-8271922a-e889-4f04-8e87-07f0bcde890d".device = "/dev/disk/by-uuid/8271922a-e889-4f04-8e87-07f0bcde890d";
luks.devices."luks-8271922a-e889-4f04-8e87-07f0bcde890d".keyFile = "/crypto_keyfile.bin";
};
kernelPackages = pkgs.linuxPackages_latest;
};
environment.systemPackages = [
pkgs.fprintd
];
services = {
# Enable fingerprint sensor
fprintd = {
enable = true;
};
# Enable touchpad support (enabled default in most desktopManager).
xserver.libinput = {
enable = true;
touchpad = {
naturalScrolling = true;
middleEmulation = true;
tapping = true;
};
};
};
}