This repository has been archived on 2024-03-26. You can view files and clone it, but cannot push or open issues or pull requests.
nixos/hosts/hermes/home.nix
Payas Relekar 5daf7e41b5 gitea -> forgejo
Also need to perform one-time migration:
https://nixos.org/manual/nixos/unstable/#module-forgejo
2024-03-16 17:01:07 +05:30

75 lines
1.3 KiB
Nix

{ pkgs, ... }:
{
imports = [
../../modules/common-home.nix
../../modules/neovim/nvim.nix
../../modules/emacs/emacs.nix
../../modules/mail/gmail.nix
./dev-home.nix
];
home.packages = with pkgs; [
# security
keepassxc # password management
rage # secrets management
# apps
vlc
strawberry
picard # tag music tracks
nicotine-plus
freetube
ansel
# utilities
youtube-dl
qbittorrent
digikam
okular
kcalc
ark # munging archives
unrar # So ark can open .rar files
spectacle
gwenview
kate
partition-manager
libreoffice # thoroughly average grown up stuff
hugo
qpdf
steam-run
arianna # epub reader for plasma
kolourpaint # paint for plasma
# Fancy AI shit
ollama
];
programs = {
go.enable = true;
ssh = {
enable = true;
matchBlocks = {
"ssh.bhankas.org" = {
user = "forgejo";
hostname = "ssh.bhankas.org";
identityFile = [ "~/.ssh/id_ed25519" ];
proxyCommand = "${pkgs.cloudflared}/bin/cloudflared access ssh --hostname %h";
};
};
};
};
gtk = {
enable = true;
theme = {
package = pkgs.gnome.gnome-themes-extra;
name = "Adwaita-dark";
};
};
}