This repository has been archived on 2024-03-26. You can view files and clone it, but cannot push or open issues or pull requests.
nixos/hosts/hermes/syncthing.nix
Payas Relekar 7a06bf52eb Revert "syncthing: add mail dir"
This reverts commit adbaa9ebbc.

Turns out, mbsync adds hostname to every mail file. And that makes
things pretty awkward, often syncthing same mail file multiple times.
Since I do not expect to have hermes and phoebe running simultaneously
most of the time, I think it is fine to sync mail to both independently
of each other.
2023-11-14 15:12:32 +05:30

62 lines
1.5 KiB
Nix

{ ... }:
{
imports = [
../../modules/common-syncthing.nix
];
services.syncthing = {
guiAddress = "127.0.0.1:8384";
settings = {
folders = {
Keepass = {
enable = true;
devices = [ "bebop" "Childish Tycoon" "phoebe" ];
type = "sendreceive";
fsWatcherEnabled = true;
versioning = {
type = "simple";
params.keep = "5";
};
};
Syncthing = {
enable = true;
devices = [ "bebop" "Childish Tycoon" "phoebe" ];
type = "sendreceive";
fsWatcherEnabled = true;
versioning = {
type = "staggered";
params = {
cleanInterval = "3600";
maxAge = "31536000";
};
};
};
org = {
enable = true;
devices = [ "bebop" "Childish Tycoon" "phoebe" ];
type = "sendreceive";
fsWatcherEnabled = true;
};
Music = {
enable = true;
devices = [ "bebop" "Childish Tycoon" "phoebe" ];
type = "sendreceive";
fsWatcherEnabled = true;
};
Pictures = {
enable = false;
# Kept as future reminder
devices = [ ]; # no pause option in NixOS module, no sharing is as good as paused
type = "sendreceive";
fsWatcherEnabled = false; # disabled folder, no need to fsWatcherEnabled
};
};
};
};
}