This repository has been archived on 2024-03-26. You can view files and clone it, but cannot push or open issues or pull requests.
nixos/modules/common.nix
Payas Relekar c952bd1a7b common: replace jq with fx
Since I have nearly never used jq the language and have only ever used
it as json pretty printer, fx is a better and lighter and more nicer alternative.
2023-09-19 18:56:04 +05:30

28 lines
736 B
Nix

{ pkgs, ... }:
{
security.sudo.wheelNeedsPassword = false;
environment.systemPackages = with pkgs; [
neovim # basic editing. No, nano is not it
git # version control
ripgrep # grep, but better
fx # For occasional json viewing
fd # find, but better
htop # top, but better
wget # curl, but kinda better
fzf # fuzzy search in command line
nix-output-monitor
deploy-rs
(
let base = pkgs.appimageTools.defaultFhsEnvArgs; in
pkgs.buildFHSUserEnv (base // {
name = "fhs";
targetPkgs = pkgs: (base.targetPkgs pkgs) ++ [ pkgs.pkg-config ];
profile = "export FHS=1";
runScript = "fish";
extraOutputsToInstall = [ "dev" ];
})
)
];
}