This repository has been archived on 2024-03-26. You can view files and clone it, but cannot push or open issues or pull requests.
nixos/modules/neovim/nvim.nix
2024-03-14 15:48:18 +05:30

25 lines
426 B
Nix

{ pkgs, ... }:
{
xdg.configFile = {
"nvim/init.lua" = {
source = ./init.lua;
};
};
programs = {
neovim = {
enable = true;
vimAlias = true;
withPython3 = false;
withRuby = false;
withNodeJs = false;
plugins = with pkgs.vimPlugins; [
nvim-treesitter.withAllGrammars
neogit
orgmode
lualine-nvim
gleam-vim
];
};
};
}