This repository has been archived on 2024-03-26. You can view files and clone it, but cannot push or open issues or pull requests.
nixos/modules/users.nix
Payas Relekar c99666fb86 users: Add payas to dialout and tty groups
Because esphome requires them for writing out to serial connection
2023-12-23 22:44:39 +05:30

27 lines
572 B
Nix
Raw Permalink Blame History

This file contains ambiguous Unicode characters

This file contains Unicode characters that might be confused with other characters. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

{ config, pkgs, ... }:
let
payas = "payas";
in
{
# Define a user account. Don't forget to set a password with passwd.
users =
{
users.payas = {
isNormalUser = true;
extraGroups = [ "wheel" "networkmanager" "adbusers" "docker" "libvirtd" "dialout" "tty" ];
home = "/home/${payas}";
description = payas;
group = "payas";
};
groups = {
input.members = [ payas ];
payas = {
name = "payas";
members = [ "payas" ];
gid = 1666;
};
};
};
}